Jump to content


Photo

Printing only yields blank pages on Sierra 10.12.4


  • Please log in to reply
2 replies to this topic

#1 DonDon

DonDon

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 21 April 2017 - 04:58 PM

Hello Storyist team,

 

I am running the latest version of Storyist (3.4.2) on the latest version of macOS (10.12.4). The problem I'm having is that when trying to print, all I get are blank pages. My document is 86 pages right now and I get 86 pages of blankness. I've tried "Open PDF in Preview" and "Save as PDF and all it leads to is blank. I've even tried selecting different printers: nada, zip, all blank.

 

The only way I can print my document, currently, is by exporting it into other file formats. This luckily works but it's very frustrating to not be able to print directly from Storyist.

 

Attached is an image of what I'm seeing when attempting to print. I've forwarded to page 9, as an example, but it doesn't matter which page I go to: it's all blank.

Attached Thumbnails

  • Screen Shot 2017-04-21 at 12.51.11.jpg


#2 Steve

Steve

    Administrator

  • Root Admin
  • PipPipPip
  • 3,809 posts
  • Gender:Male

Posted 21 April 2017 - 05:12 PM

Hi DonDon,

 

You're running into an apparent bug in 10.12.4 that affects printing text at zoom factors that are not ratios of small integers. You're not the only one.

 

Here is the work-around for Storyist 3.4.2 and earlier:

  1. Open your project and navigate to the text file you want to print.
  2. Set the zoom factor to 100%, 125%, 150%, or 175%. (You can use the View > Zoom > Zoom Out/In menu command to do this).
  3. Choose File > Print.

Storyist 3.4.3 sets the zoom factor for you if you're running Sierra (and then sets it back after printing). This version is currently in testing, but you're welcome to use it. You can download it here.

 

-Steve



#3 DonDon

DonDon

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 21 April 2017 - 05:16 PM

Thanks for the quick reply! Okay, I've just selected  View > Zoom > Actual Size and it worked. Also, thanks for offering the Beta download, very kind of you.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users